You must be logged in to post messages.
Please login or register

Modpack Discussion
Moderated by Crazed Ewok, Gen_Rhys_Dallows

Hop to:    
Welcome! You are not logged in. Please Login or Register.65 replies, Sticky
SWGB Heaven » Forums » Modpack Discussion » Expanding Fronts Troubleshooting
Bottom
Topic Subject:Expanding Fronts Troubleshooting
« Previous Page  1 2 3  Next Page »
Gen_Rhys_Dallows
Jedi Knight
posted 07-01-14 04:01 PM EDT (US)         



UPDATED 1 JUL 2018

Due to numerous new threads littering GBH concerning Expanding Fronts issues, I'm making this thread dedicated to troubleshooting the various problems users have been experiencing with the Beta. Any issues you come across should be posted here.

NOTE: This thread is for problems pertaining to the mod's performance. Suggestions concerning balance, new units/features, or any other questions/comments should be posted in the main EF thread

Frequently Asked Questions:

The installer does not work or gives me an error.
Download the manual installation archive instead. Installation is a very simple process, and instructions are included with the download.

Attempting to launch the game gives the following error: "The application was unable to start correctly (0xc000007b)."
Install Visual C++ Redistributable for Visual Studio 2015 available at https://www.microsoft.com/en-us/download/details.aspx?id=48145
(If link doesn't work, try copy-pasting into your browser)

Attempting to launch the game gives the following error: "The program can't start because VCRYNTIME140.dll is missing from your computer."
Install Visual C++ Redistributable for Visual Studio 2015 available at https://www.microsoft.com/en-us/download/details.aspx?id=48145
(If link doesn't work, try copy-pasting into your browser)

I do not see some of the new features of the mod (Larger maps, etc).
Some additional features of the mod must be enabled via the Configuration tool.

The game still fails to launch after installing Visual C++ Redistributable for Visual Studio 2015, or attempting to launch the game gives an error that efpatch.dll fails to load.
Try installing Dependency Walker (x86 version) and opening efpatch.dll with it: http://www.dependencywalker.com/

How do I change my resolution?
The Configurator tool will allow you to select your preferred resolution.

My game only displays in the corner of the screen, and the rest of the screen appears pink.
Ensure that the in-game resolution option is set to its highest available setting.

My game is randomly crashing.
Disable DSound Hook in the Configurator if you are experiencing crashes.

How do I access the configuration tool?
The option to open the configuration tool should appear each time you run battlegrounds_x2.exe. If it does not, either hold SHIFT while launching the game or open configurator.exe, located in SWGB's Game folder.

I do not see any changes when I run the game.
Ensure that all files are installed to their proper location, and that you are running the 'Battlegrounds_X2.exe' file to launch the mod.

My colors are glitched; there are red/green pixels all over the screen.
To fix this issue, download the DirectDraw fix from aok.heavengames.com, and apply it to your Battlegrounds_x2.exe file.

The user interface is missing and appears only magenta (purple/pink colored).
Install Expanding Fronts on a clean installation of the game. Installing Expanding Fronts with the "All in one patch," or other widescreen-enabling mods may cause this error.

Online matches frequently go out of sync.
Ensure that all players are using the same version of the mod, and that all files are properly installed.

I want to play through GameRanger, but I cannot select Battlegrounds_x2 as my game.
To play through GameRanger, move or rename your normal Battlegrounds_x1.exe file. Once moved, rename your Battlegrounds_x2.exe to x1. GameRanger should now detect this as your game. Be sure to return the files to their proper names/places when finished playing.

The screen is too big with widescreen patch enabled, lower bottom part of the screen is cut off.
Disable high DPI scaling in file properties (compatibility -> disable scaling on high DPI screens).

I am experiencing problems with pathfinding, or object placement issues on large maps.
Large map support is still experimental, and using sizes larger than 255x255 may have unpredictable results

I'm experiencing other issues (such as missing graphics).
The mod may not be installed correctly. Try installing the base game and Expanding Fronts to a location outside of Program Files, in a directory where a standard, non-elevated Windows user is allowed to write to.

This list will be updated as more issues arise.

ARMY STRONG
"Rhys wins this thread." - Tsavong Lah | "Gen freakin wins." - Jon Rolos | "...Any mercenary force trained by you, Dallows, would be all kinds of awesome." - Flying Ace
Expanding Fronts Mod

[This message has been edited by Gen_Rhys_Dallows (edited 07-01-2018 @ 06:33 PM).]

AuthorReplies:
Emissary of the Prophets
Clone Trooper
(id: Admiral Zaarin)
posted 07-07-17 09:11 PM EDT (US)     26 / 65       
It's slower, but does the Disable Units trigger still work for you?

Zaarin | Creator of Coruscant Life SE
deviantArt | New Campaign Coming Soon
"But if of ships I now should sing, what ship would come to me,
What ship would bear me ever back across so wide a Sea?

"Most forums derails into talking about memes. Here we derail into in-depth discussions about art. I like ours better."--jssf1992
abcdefghijk
Clone Trooper
posted 07-07-17 09:21 PM EDT (US)     27 / 65       
Boy, I feel like an idiot.

Yeah, the Disable Units trigger works...

I completely forgot about that. Thanks though
rva2895
Clone Trooper
posted 07-08-17 09:17 AM EDT (US)     28 / 65       
Whenever I select the Disable Units button in the options tab of the Scenario editor (The one that lets you get to pick if someone cant create a certain unit in-game), the game immediately crashes.
This is a known bug and it has been fixed. Grab the newest version from google drive.
Brenz
Clone Trooper
posted 07-09-17 06:10 PM EDT (US)     29 / 65       
I have trouble with the scenario editor, whenever I go to options and try to click on the disable units button, the game crashes every single time. Does anybody know what the problem might be and how to fix this? I just want to disable one unit but I can't!!!
Emissary of the Prophets
Clone Trooper
(id: Admiral Zaarin)
posted 07-09-17 08:04 PM EDT (US)     30 / 65       
Literally the post right above yours...

Zaarin | Creator of Coruscant Life SE
deviantArt | New Campaign Coming Soon
"But if of ships I now should sing, what ship would come to me,
What ship would bear me ever back across so wide a Sea?

"Most forums derails into talking about memes. Here we derail into in-depth discussions about art. I like ours better."--jssf1992
cutedogruffruff
Clone Trooper
posted 08-14-17 11:07 AM EDT (US)     31 / 65       
Having trouble with instalation. Using the gog version and I have windows 10. I did the manual installation with 1.1 but it keeps giving me an error message of 0xc0000022. Even trying to play the game without the mod gives me the same error. Anyone else have this problem? How do I fix it?
Darth Kiro
Clone Trooper
posted 08-16-17 00:59 AM EDT (US)     32 / 65       
Could you play the game before you download the mod, or you are doing that for the first time? If yes, the problem must has appeared during the installation try and if you play the game for the first time, the problem may come from you; one thing, I am not sure how slightly does SWGB run on windows 10.
cutedogruffruff
Clone Trooper
posted 08-16-17 10:50 AM EDT (US)     33 / 65       
Could not play before hand either. I guess the vanilla game is incompatible with w10. Steam version did update to work with it though so I will try installing using steam version.
voxynlover
Clone Trooper
posted 09-03-17 02:01 PM EDT (US)     34 / 65       
so the game starts out choppy and glitchy. crashes after about a minute when i load a saved confederacy game. i dont have this issue with any other civ and it seems not to matter which map. if i play straight through w/o exiting the game its fine. only when i load a conf. save does it happen.

help me please
Chasi Weran
Clone Trooper
posted 10-03-17 08:16 PM EDT (US)     35 / 65       
I'm trying to launch the game, but apparently the process lasts for a second, and then removes itself. It happens every time I double click "battlegrounds_x2"
rva2895
Clone Trooper
posted 10-03-17 08:28 PM EDT (US)     36 / 65       
Does the configurator open when you hold SHIFT while double clicking the exe?
That_Nate_Guy
Clone Trooper
posted 12-23-17 09:30 PM EDT (US)     37 / 65       
NEED HELP WITH INSTALL

I have attempted multiple times, to install SWBG: EF. I'm very computer savy, but alas - this mod does not want to cooperate. On http://www.moddb.com/mods/star-wars-galactic-battlegrounds-expanding-fronts/downloads I have attempted installing using the: Expanding Fronts 1.1 (Exe Installer). Once this was done, upon opening the "battlegrounds_x2" exe, it just starts up regular ol' clone wars. Somewhere else on this board, it was suggested to also get the patch. So I downloaded the Expanding Fronts 1.1.1 Patch. This also failed.

Aggravated, and determined to try this mod out, I eventually downloaded and installed the manual file: Expanding Fronts 1.1 (Manual Install Archive). This still had the same result. Once again elsewhere it was suggested to download the older version just as a base line to see if it would work. I did. Now, in stead of clone wars coming up, the game crashes altogether.

To say I'm merely annoyed would be an understatement. It doesn't help that the config file for the installer isn't even included. Any help or advice would be appreciated as my friends and family play clone wars and would be most interested in giving EF a try; however, we can't seem to even get it running and are growing tired of trying. It is a shame to not get to see the modders' hard work in action. : (
Tevious
Clone Trooper
(id: The Vampire Slayer)
posted 12-24-17 09:56 AM EDT (US)     38 / 65       
upon opening the "battlegrounds_x2" exe, it just starts up regular ol' clone wars
Are you sure it isn't Expanding Fronts? We hadn't made any menu changes until this new upcoming release, so even though it says Clone Campaigns, it's really Expanding Fronts.

Hold SHIFT when you click on battlegrounds_x2.exe to get to the configurator if you are wanting to change resolution settings. The in-game resolution should be the largest one for that to work.

@)₪₪₪₪ ŤΣVŮS ₪₪₪₪(@
|| OŢ .◊ ŤΡМ ◊. SLX ||
|| ŘĿŦŔ .◊ ŦŚŤĮ ◊. ĶǾŤ ||
@)₪₪₪₪₪₪₪₪₪₪₪₪₪(@
Maladict
Clone Trooper
posted 01-05-18 12:26 PM EDT (US)     39 / 65       
Hey,

I've installed the latest version (1.2) from ModDB, and it installed fine & the scenario editor worked with no problems, but when I actually play a game the bottom UI is all vivid pink. I could deal with that irritation, but also each time I select something new the old thing doesn't vanish from the UI, so I end up with buttons/names/stats all overlapping each other and making it impossible to tell what I actually have selected. Screenshot: https://i.imgur.com/zIMbW7r.png

Someone else commented with the same issue on reddit, and on ModDB. Is there a fix/workaround for this, please?

Thanks very much.
Tevious
Clone Trooper
(id: The Vampire Slayer)
posted 01-05-18 03:48 PM EDT (US)     40 / 65       
Dallows is away for the weekend and can't update the post, so I will update the FAQ here:


[RETRACTED]

@)₪₪₪₪ ŤΣVŮS ₪₪₪₪(@
|| OŢ .◊ ŤΡМ ◊. SLX ||
|| ŘĿŦŔ .◊ ŦŚŤĮ ◊. ĶǾŤ ||
@)₪₪₪₪₪₪₪₪₪₪₪₪₪(@

[This message has been edited by Tevious (edited 06-30-2018 @ 08:05 PM).]

Captain Keno
Clone Trooper
posted 01-05-18 09:54 PM EDT (US)     41 / 65       
Install Visual C++ Redistributable for Visual Studio 2015 available
That's the easiest answer I got to solve this problem and I am already working on that now.

Also, thank you for the feedback.
Maladict
Clone Trooper
posted 01-06-18 05:21 AM EDT (US)     42 / 65       
The user interface is missing and appears only magenta (purple/pink colored).
Install Expanding Fronts on a clean installation of the game. Installing Expanding Fronts with the "All in one patch" will cause this error. Other widescreen patches (not from EF) may cause this problem as well.
This worked for me, thanks for the help!
obiwan blue
Clone Trooper
posted 01-14-18 05:08 PM EDT (US)     43 / 65       
I tried to install it . but it says a program error has eccord reinstall might fix this that's what i did when i install it that error box just pop out how do i get in the program.
Tevious
Clone Trooper
(id: The Vampire Slayer)
posted 01-15-18 02:29 AM EDT (US)     44 / 65       
obiwan blue, have you tried all the solutions in the FAQ? Replace the battlegrounds_x2.exe with the one linked in the OP. If that doesn't work, try installing C++ Redistributable for Visual Basic 2015. If that doesn't work, reinstall the game and make sure you aren't installing any non-official patches.

@)₪₪₪₪ ŤΣVŮS ₪₪₪₪(@
|| OŢ .◊ ŤΡМ ◊. SLX ||
|| ŘĿŦŔ .◊ ŦŚŤĮ ◊. ĶǾŤ ||
@)₪₪₪₪₪₪₪₪₪₪₪₪₪(@
obiwan blue
Clone Trooper
posted 01-15-18 05:18 PM EDT (US)     45 / 65       
i got it it works like a charm now thank you.
av29
Clone Trooper
posted 01-16-18 08:35 AM EDT (US)     46 / 65       
The game works well, but after 10 seconds or so makes a little 1 second delay and then if I try to enter the chat or save the game, it freezes, but the sounds of units and music still work.

Similar to this: https://steamcommunity.com/app/356500/discussions/0/1488866180613035350/
av29
Clone Trooper
posted 01-27-18 11:48 AM EDT (US)     47 / 65       
I uninstalled the Colour patch fix, and seems that it's not (edit) the cause of the bug.

[This message has been edited by av29 (edited 02-05-2018 @ 02:33 PM).]

av29
Clone Trooper
posted 02-05-18 02:35 PM EDT (US)     48 / 65       
Sorry with the message of before, I missed the not*. It's a pity that there isn't something like userpatch for SWGB.
jedediahvail
Clone Trooper
posted 02-08-18 00:37 AM EDT (US)     49 / 65       
Hi!
I am a Mac user and I have SWGB installed using Porting Kit. If you are familiar with that program, I was wondering if it is possible for me to use this mod.

I have run the .exe installer but after installing Expanding Fronts the game didn't launch. It said that the .exe file to launch SWGB was missing.
I then tried to manually swap the "Game" folders which brought up the same prompt.

I believe the problem is that Porting Kit is attempting to run battlegrounds_x1.exe and that to use Expanding Fronts I should run battlegrounds_x2.exe

I just can't seem to get it to work.

I understand if you don't know a solution since I'm on Mac and using a port.

Thanks!


Edit: Found a solution on macgaming subreddit. Looking forward to playing this!

Edit 2: It's still not working. pls help I wanna play this awesome mod.

[This message has been edited by jedediahvail (edited 02-08-2018 @ 07:48 PM).]

Captain Keno
Clone Trooper
posted 02-15-18 11:40 AM EDT (US)     50 / 65       
Tevious, I don't wanna say anything before... I didn't really because I was very busy, but just speaking professionally... The download link you provided for the Visual C++ Redistributable for Visual Studio is wrong. It just shows the one for some excel program, I think. You might wanna check it yourself.

[This message has been edited by Captain Keno (edited 02-15-2018 @ 11:40 AM).]

« Previous Page  1 2 3  Next Page »
You must be logged in to post messages.
Please login or register

Hop to:    

SWGB Heaven | HeavenGames